Degraded O365 job performance

Incident Report for m105

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 05:01 UTC

Monitoring

The issue is resolved,and backups are running as expected. We continue to monitor.
Posted Jan 29, 2026 - 12:09 UTC

Investigating

We experienced degraded performance impacting some of Office 365 backup jobs. The issue is resolved, and backups are running as expected. We continue to monitor.
Posted Jan 29, 2026 - 12:08 UTC